const regex = /Local[ \t]+(?<class>\w+(?:\[\])?)[ \t](\w+)[ \t]+=/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Local[ \\t]+(?<class>\\w+(?:\\[\\])?)[ \\t](\\w+)[ \\t]+=', 'gm')
const str = `
Local tLevel Lvl = tLevel.Get(LvlName);
Local tLevel Lvl = tLevel.Get(LvlName);
Local tLevel[] Lvl = tLevel.Get(LvlName);
Local UpdMods = 0;
Local Box hm= new Box();
Local class[] x => class[] x`;
const subst = `$1 $2 =`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);