$re = '/Local[ \t]+(?<class>\w+(?:\[\])?)[ \t](\w+)[ \t]+=/m';
$str = '
Local tLevel Lvl = tLevel.Get(LvlName);
Local tLevel Lvl = tLevel.Get(LvlName);
Local tLevel[] Lvl = tLevel.Get(LvlName);
Local UpdMods = 0;
Local Box hm= new Box();
Local class[] x => class[] x';
$subst = "$1 $2 =";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;