re = /Local[ \t]+(?<class>\w+(?:\[\])?)[ \t](\w+)[ \t]+=/m
str = '
Local tLevel Lvl = tLevel.Get(LvlName);
Local tLevel Lvl = tLevel.Get(LvlName);
Local tLevel[] Lvl = tLevel.Get(LvlName);
Local UpdMods = 0;
Local Box hm= new Box();
Local class[] x => class[] x'
subst = '$1 $2 ='
result = str.gsub(re, subst)
# Print the result of the substitution
puts result