import Foundation
let pattern = #"Local[ \t]+(?<class>\w+(?:\[\])?)[ \t](\w+)[ \t]+="#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Local tLevel Lvl = tLevel.Get(LvlName);
Local tLevel Lvl = tLevel.Get(LvlName);
Local tLevel[] Lvl = tLevel.Get(LvlName);
Local UpdMods = 0;
Local Box hm= new Box();
Local class[] x => class[] x
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2 ="#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)