// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Local[ \t]+(?<class>\w+(?:\[\])?)[ \t](\w+)[ \t]+=").unwrap();
let string = "
Local tLevel Lvl = tLevel.Get(LvlName);
Local tLevel Lvl = tLevel.Get(LvlName);
Local tLevel[] Lvl = tLevel.Get(LvlName);
Local UpdMods = 0;
Local Box hm= new Box();
Local class[] x => class[] x";
let substitution = "$1 $2 =";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}