# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\(((?:[^()]++|(?1))*)\))\^(\d*\.?\d+)/pow(\2, \3)/g;t' <<< "((2-x+3)^2+(x-5+7)^10)^0.5
pow((2-x+3)^2+(x-5+7)^10, 0.5)"