// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\(((?:[^()]++|(?1))*)\))\^(\d*\.?\d+)").unwrap();
let string = "((2-x+3)^2+(x-5+7)^10)^0.5
pow((2-x+3)^2+(x-5+7)^10, 0.5)";
let substitution = "pow(\\2, \\3)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}