using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\(((?:[^()]++|(?1))*)\))\^(\d*\.?\d+)";
string substitution = @"pow(\2, \3)";
string input = @"((2-x+3)^2+(x-5+7)^10)^0.5
pow((2-x+3)^2+(x-5+7)^10, 0.5)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}