use strict;
my $str = '((2-x+3)^2+(x-5+7)^10)^0.5
pow((2-x+3)^2+(x-5+7)^10, 0.5)';
my $regex = qr/(\(((?:[^()]++|(?1))*)\))\^(\d*\.?\d+)/p;
my $subst = 'pow(\\2, \\3)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";