const regex = /(\(((?:[^()]++|(?1))*)\))\^(\d*\.?\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\(((?:[^()]++|(?1))*)\\))\\^(\\d*\\.?\\d+)', 'g')
const str = `((2-x+3)^2+(x-5+7)^10)^0.5
pow((2-x+3)^2+(x-5+7)^10, 0.5)`;
const subst = `pow(\2, \3)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);