package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\(((?:[^()]++|(?1))*)\))\^(\d*\.?\d+)`)
var str = `((2-x+3)^2+(x-5+7)^10)^0.5
pow((2-x+3)^2+(x-5+7)^10, 0.5)`
var substitution = "pow(\2, \3)"
fmt.Println(re.ReplaceAllString(str, substitution))
}