#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\(((?:[^()]++|(?1))*)\))\^(\d*\.?\d+)"
Local $sString = "((2-x+3)^2+(x-5+7)^10)^0.5" & @CRLF & _
"pow((2-x+3)^2+(x-5+7)^10, 0.5)"
Local $sSubst = "pow(\2, \3)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)