import re
regex = re.compile(r"(\(((?:[^()]++|(?1))*)\))\^(\d*\.?\d+)")
test_str = ("((2-x+3)^2+(x-5+7)^10)^0.5\n"
"pow((2-x+3)^2+(x-5+7)^10, 0.5)")
subst = "pow(\\2, \\3)"
result = regex.sub(subst, test_str)
if result:
print(result)