import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\(((?:[^()]++|(?1))*)\\))\\^(\\d*\\.?\\d+)";
final String string = "((2-x+3)^2+(x-5+7)^10)^0.5\n"
+ "pow((2-x+3)^2+(x-5+7)^10, 0.5)";
final String subst = "pow(\\2, \\3)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}