# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bchocolate(?:(?:\hvanilla)?\hcookies)?\b/chocolate chip cookies/gm;t' <<< "Try out our new chocolate
Try out our new chocolate cookies
Try out our new chocolate vanilla cookies"