#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\bchocolate(?:(?:\hvanilla)?\hcookies)?\b"
Local $sString = "Try out our new chocolate" & @CRLF & _
"Try out our new chocolate cookies" & @CRLF & _
"Try out our new chocolate vanilla cookies"
Local $sSubst = "chocolate chip cookies"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)