import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bchocolate(?:(?:\\hvanilla)?\\hcookies)?\\b";
final String string = "Try out our new chocolate\n"
+ "Try out our new chocolate cookies\n"
+ "Try out our new chocolate vanilla cookies";
final String subst = "chocolate chip cookies";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}