using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bchocolate(?:(?:\hvanilla)?\hcookies)?\b";
string substitution = @"chocolate chip cookies";
string input = @"Try out our new chocolate
Try out our new chocolate cookies
Try out our new chocolate vanilla cookies";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}