package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bchocolate(?:(?:\hvanilla)?\hcookies)?\b`)
var str = `Try out our new chocolate
Try out our new chocolate cookies
Try out our new chocolate vanilla cookies`
var substitution = "chocolate chip cookies"
fmt.Println(re.ReplaceAllString(str, substitution))
}