const regex = /\bchocolate(?:(?:\hvanilla)?\hcookies)?\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bchocolate(?:(?:\\hvanilla)?\\hcookies)?\\b', 'gm')
const str = `Try out our new chocolate
Try out our new chocolate cookies
Try out our new chocolate vanilla cookies`;
const subst = `chocolate chip cookies`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);