re = /\bchocolate(?:(?:\hvanilla)?\hcookies)?\b/m
str = 'Try out our new chocolate
Try out our new chocolate cookies
Try out our new chocolate vanilla cookies'
subst = 'chocolate chip cookies'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result