use strict;
my $str = 'Try out our new chocolate
Try out our new chocolate cookies
Try out our new chocolate vanilla cookies';
my $regex = qr/\bchocolate(?:(?:\hvanilla)?\hcookies)?\b/mp;
my $subst = 'chocolate chip cookies';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";