$re = '/\bchocolate(?:(?:\hvanilla)?\hcookies)?\b/m';
$str = 'Try out our new chocolate
Try out our new chocolate cookies
Try out our new chocolate vanilla cookies';
$subst = "chocolate chip cookies";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;