// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bchocolate(?:(?:\hvanilla)?\hcookies)?\b").unwrap();
let string = "Try out our new chocolate
Try out our new chocolate cookies
Try out our new chocolate vanilla cookies";
let substitution = "chocolate chip cookies";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}