# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((https:\\/\\/web.archive.org\\/web\\/\d*)(\\/https?:\\/\\/?(www\.)?.*))/$2if_$3/gm;t' <<< "https://web.archive.org/web/20210709181138if_/https://www.cualquierdominio.es/slug/contenido.html
https://web.archive.org/web/20210709181138/http://www.dominioaceptable.com/slug/contenido.php
https://web.archive.org/web/20210709181138/http://dominiobaneado.co.uk/slug/contenido.html?id=324
https://web.archive.org/web/20210709181138/https://dominiosnuevos.info/slug
"