package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((https:\/\/web.archive.org\/web\/\d*)(\/https?:\/\/?(www\.)?.*))`)
var str = `https://web.archive.org/web/20210709181138if_/https://www.cualquierdominio.es/slug/contenido.html
https://web.archive.org/web/20210709181138/http://www.dominioaceptable.com/slug/contenido.php
https://web.archive.org/web/20210709181138/http://dominiobaneado.co.uk/slug/contenido.html?id=324
https://web.archive.org/web/20210709181138/https://dominiosnuevos.info/slug
`
var substitution = "$2if_$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}