use strict;
my $str = 'https://web.archive.org/web/20210709181138if_/https://www.cualquierdominio.es/slug/contenido.html
https://web.archive.org/web/20210709181138/http://www.dominioaceptable.com/slug/contenido.php
https://web.archive.org/web/20210709181138/http://dominiobaneado.co.uk/slug/contenido.html?id=324
https://web.archive.org/web/20210709181138/https://dominiosnuevos.info/slug
';
my $regex = qr/((https:\/\/web.archive.org\/web\/\d*)(\/https?:\/\/?(www\.)?.*))/mp;
my $subst = '$2if_$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";