const regex = /((https:\/\/web.archive.org\/web\/\d*)(\/https?:\/\/?(www\.)?.*))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((https:\\\/\\\/web.archive.org\\\/web\\\/\\d*)(\\\/https?:\\\/\\\/?(www\\.)?.*))', 'gm')
const str = `https://web.archive.org/web/20210709181138if_/https://www.cualquierdominio.es/slug/contenido.html
https://web.archive.org/web/20210709181138/http://www.dominioaceptable.com/slug/contenido.php
https://web.archive.org/web/20210709181138/http://dominiobaneado.co.uk/slug/contenido.html?id=324
https://web.archive.org/web/20210709181138/https://dominiosnuevos.info/slug
`;
const subst = `$2if_$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);