import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((https:\\/\\/web.archive.org\\/web\\/\\d*)(\\/https?:\\/\\/?(www\\.)?.*))";
final String string = "https://web.archive.org/web/20210709181138if_/https://www.cualquierdominio.es/slug/contenido.html\n"
+ "https://web.archive.org/web/20210709181138/http://www.dominioaceptable.com/slug/contenido.php\n"
+ "https://web.archive.org/web/20210709181138/http://dominiobaneado.co.uk/slug/contenido.html?id=324\n"
+ "https://web.archive.org/web/20210709181138/https://dominiosnuevos.info/slug\n";
final String subst = "$2if_$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}