# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((https:\/\/web.archive.org\/web\/\d*)(\/https?:\/\/?(www\.)?.*))"
test_str = ("https://web.archive.org/web/20210709181138if_/https://www.cualquierdominio.es/slug/contenido.html\n"
"https://web.archive.org/web/20210709181138/http://www.dominioaceptable.com/slug/contenido.php\n"
"https://web.archive.org/web/20210709181138/http://dominiobaneado.co.uk/slug/contenido.html?id=324\n"
"https://web.archive.org/web/20210709181138/https://dominiosnuevos.info/slug\n")
subst = "$2if_$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.