#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((https:\/\/web.archive.org\/web\/\d*)(\/https?:\/\/?(www\.)?.*))"
Local $sString = "https://web.archive.org/web/20210709181138if_/https://www.cualquierdominio.es/slug/contenido.html" & @CRLF & _
"https://web.archive.org/web/20210709181138/http://www.dominioaceptable.com/slug/contenido.php" & @CRLF & _
"https://web.archive.org/web/20210709181138/http://dominiobaneado.co.uk/slug/contenido.html?id=324" & @CRLF & _
"https://web.archive.org/web/20210709181138/https://dominiosnuevos.info/slug" & @CRLF & _
""
Local $sSubst = "$2if_$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)