re = /((https:\/\/web.archive.org\/web\/\d*)(\/https?:\/\/?(www\.)?.*))/m
str = 'https://web.archive.org/web/20210709181138if_/https://www.cualquierdominio.es/slug/contenido.html
https://web.archive.org/web/20210709181138/http://www.dominioaceptable.com/slug/contenido.php
https://web.archive.org/web/20210709181138/http://dominiobaneado.co.uk/slug/contenido.html?id=324
https://web.archive.org/web/20210709181138/https://dominiosnuevos.info/slug
'
subst = '$2if_$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result