using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((https:\/\/web.archive.org\/web\/\d*)(\/https?:\/\/?(www\.)?.*))";
string substitution = @"$2if_$3";
string input = @"https://web.archive.org/web/20210709181138if_/https://www.cualquierdominio.es/slug/contenido.html
https://web.archive.org/web/20210709181138/http://www.dominioaceptable.com/slug/contenido.php
https://web.archive.org/web/20210709181138/http://dominiobaneado.co.uk/slug/contenido.html?id=324
https://web.archive.org/web/20210709181138/https://dominiosnuevos.info/slug
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}