#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im).*word.*$"
Local $sString = "aslkdjlsajd fjsafjlasjfg" & @CRLF & _
"sakjfslajf word mdsngdsnglkjds" & @CRLF & _
"cbcb cbfgntfh thrtjrtityi" & @CRLF & _
"" & @CRLF & _
"dghdhfdh dfhdfh dfhdfjdfjdfj" & @CRLF & _
"sfasfsaf ryrtutru Word" & @CRLF & _
"detwt weyrutru kughngnse"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)