const regex = /.*word.*$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*word.*$', 'gim')
const str = `aslkdjlsajd fjsafjlasjfg
sakjfslajf word mdsngdsnglkjds
cbcb cbfgntfh thrtjrtityi
dghdhfdh dfhdfh dfhdfjdfjdfj
sfasfsaf ryrtutru Word
detwt weyrutru kughngnse`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);