package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im).*word.*$`)
var str = `aslkdjlsajd fjsafjlasjfg
sakjfslajf word mdsngdsnglkjds
cbcb cbfgntfh thrtjrtityi
dghdhfdh dfhdfh dfhdfjdfjdfj
sfasfsaf ryrtutru Word
detwt weyrutru kughngnse`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}