import re
regex = re.compile(r".*word.*$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("aslkdjlsajd fjsafjlasjfg\n"
"sakjfslajf word mdsngdsnglkjds\n"
"cbcb cbfgntfh thrtjrtityi\n\n"
"dghdhfdh dfhdfh dfhdfjdfjdfj\n"
"sfasfsaf ryrtutru Word\n"
"detwt weyrutru kughngnse")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)