$re = '/.*word.*$/im';
$str = 'aslkdjlsajd fjsafjlasjfg
sakjfslajf word mdsngdsnglkjds
cbcb cbfgntfh thrtjrtityi
dghdhfdh dfhdfh dfhdfjdfjdfj
sfasfsaf ryrtutru Word
detwt weyrutru kughngnse';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;