re = /.*word.*$/im
str = 'aslkdjlsajd fjsafjlasjfg
sakjfslajf word mdsngdsnglkjds
cbcb cbfgntfh thrtjrtityi
dghdhfdh dfhdfh dfhdfjdfjdfj
sfasfsaf ryrtutru Word
detwt weyrutru kughngnse'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result