import Foundation
let pattern = #".*word.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
aslkdjlsajd fjsafjlasjfg
sakjfslajf word mdsngdsnglkjds
cbcb cbfgntfh thrtjrtityi
dghdhfdh dfhdfh dfhdfjdfjdfj
sfasfsaf ryrtutru Word
detwt weyrutru kughngnse
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)