import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*word.*$";
final String string = "aslkdjlsajd fjsafjlasjfg\n"
+ "sakjfslajf word mdsngdsnglkjds\n"
+ "cbcb cbfgntfh thrtjrtityi\n\n"
+ "dghdhfdh dfhdfh dfhdfjdfjdfj\n"
+ "sfasfsaf ryrtutru Word\n"
+ "detwt weyrutru kughngnse";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}