# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<sup>(.*?)<\\/sup>/<a href="#$1"><sup>$1<\/sup><\/a>/g;t' <<< "<sup>3</sup>
<sup>4</sup>"