import Foundation
let pattern = #"<sup>(.*?)<\/sup>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<sup>3</sup>
<sup>4</sup>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"<a href="#$1"><sup>$1</sup></a>"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)