import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<sup>(.*?)<\\/sup>";
final String string = "<sup>3</sup>\n"
+ "<sup>4</sup>";
final String subst = "<a href=\"#$1\"><sup>$1</sup></a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}