$re = '/<sup>(.*?)<\/sup>/';
$str = '<sup>3</sup>
<sup>4</sup>';
$subst = "<a href=\"#$1\"><sup>$1</sup></a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;