// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<sup>(.*?)<\/sup>").unwrap();
let string = "<sup>3</sup>
<sup>4</sup>";
let substitution = "<a href=\"#$1\"><sup>$1</sup></a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}