#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<sup>(.*?)<\/sup>"
Local $sString = "<sup>3</sup>" & @CRLF & _
"<sup>4</sup>"
Local $sSubst = "<a href="#$1"><sup>$1</sup></a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)