use strict;
my $str = '<sup>3</sup>
<sup>4</sup>';
my $regex = qr/<sup>(.*?)<\/sup>/p;
my $subst = '<a href="#$1"><sup>$1</sup></a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";