using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<sup>(.*?)<\/sup>";
string substitution = @"<a href=""#$1""><sup>$1</sup></a>";
string input = @"<sup>3</sup>
<sup>4</sup>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}