# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[0-9]+\s?[–|-]?\s?[0-9]*\s?g{0,1}\b/1/gi;t' <<< "100g Butter
100-300g Butter
100 - 300g Butter"